img
img
13 апреля 2022
16 апреля 2022
7 мин
77

Как работать с формулами в Excel

Формулы в Excel делятся на простые, сложные и комбинированные.

img
Автор статьи
Анастасия Хамидулина
Копирайтер, редактор
img

Формулы Excel используют, когда данных очень много. Например, чтобы посчитать сумму нескольких чисел быстрее, чем на калькуляторе. Преимуществ много, поэтому работодатели часто указывают эту программу в требованиях. В конце марта 2022 года 64 225 вакансий на хедхантере содержали формулировки вроде «уверенный пользователь Excel», «работа с формулами в Excel».

Кому важно знать Excel и где выучить основы

Excel нужен бухгалтерам, чтобы вести учет в таблицах. Экономистам, чтобы делать перерасчет цен, анализировать показатели компании. Менеджерам — вести базу клиентов. Аналитикам — строить и проверять гипотезы.

Программу можно освоить самостоятельно, например по статьям в интернете. Но это поможет понять только основные формулы. Если нужны глубокие знания — как строить сложные прогнозы, собирать калькулятор юнит-экономики, — пройдите курсы.

На онлайн-курсе Skypro «Аналитик данных» научитесь владеть базовыми формулами Excel, работать с нестандартными данными, статистикой. Кроме Excel вы изучите Metabase, SQL, Power BI, язык программирования Python. Программа подойдет даже тем, у кого совсем нет опыта в анализе и кто не любит математику. Вас ждут живые вебинары, мастер-классы, домашки с разбором, помощь наставников.

Курс «Аналитик данных»

Урок из курса «Аналитик данных» в Skypro

Из чего состоит формула в Excel

Основные знаки:

= с него начинают любую формулу;

( ) заключают формулу и ее части;

; применяют, чтобы указать очередность ячеек или действий;

: ставят, чтобы обозначить диапазон ячеек, а не выбирать всё подряд вручную.

В Excel работают с простыми математическими действиями:

сложением +

вычитанием —

умножением *

делением /

возведением в степень ^

Еще используют символы сравнения:

равенство =

меньше <

больше >

меньше либо равно <=

больше либо равно >=

не равно <>

Основные виды

Все формулы в Excel делятся на простые, сложные и комбинированные. Их можно написать самостоятельно или воспользоваться встроенными.

Простые

Применяют, когда нужно совершить одно простое действие, например сложить или умножить.

СУММ. Складывает несколько чисел. Сумму можно посчитать для нескольких ячеек или целого диапазона.


=СУММ(А1;В1) — для соседних ячеек;

=СУММ(А1;С1;H1) — для определенных ячеек;

=СУММ(А1:Е1) — для диапазона.

Как найти сумму всех ячеек в excel

Сумма всех чисел в ячейках от А1 до Е1

ПРОИЗВЕД. Умножает числа в соседних, выбранных вручную ячейках или диапазоне.


=ПРОИЗВЕД(А1;В1)

=ПРОИЗВЕД(А1;С1;H1)

=ПРОИЗВЕД(А1:Е1)

Как найти произведение ячеек в Excel

Произведение всех чисел в ячейках от А1 до Е1

ОКРУГЛ. Округляет дробное число до целого в большую или меньшую сторону. Укажите ячейку с нужным числом, в качестве второго значения — 0.


=ОКРУГЛВВЕРХ(А1;0) — к большему целому числу;

=ОКРУГЛВНИЗ(А1;0) — к меньшему.

Как округлить до целого числа в Excel

Округление в меньшую сторону

ВПР. Находит данные в таблице или определенном диапазоне.


=ВПР(С1;А1:В6;2)

  • С1 — ячейка, в которую выписывают известные данные. В примере это код цвета.
  • А1 по В6 — диапазон ячеек. Ищем название цвета по коду.
  • 2 — порядковый номер столбца для поиска. В нём указаны названия цвета.
Как создать функцию ВПР в Excel

Формула вычислила, какой цвет соответствует коду

СЦЕПИТЬ. Объединяет данные диапазона ячеек, например текст или цифры. Между содержимым ячеек можно добавить пробел, если объединяете слова в предложения.


=СЦЕПИТЬ(А1;В1;С1) — текст без пробелов;

=СЦЕПИТЬ(А1;" ";В1;" "С1) — с пробелами.

Как сцепить ячейки в Excel

Формула объединила три слова в одно предложение

КОРЕНЬ. Вычисляет квадратный корень числа в ячейке.


=КОРЕНЬ(А1)

Как извлечь корень в Excel

Квадратный корень числа в ячейке А1

ПРОПИСН. Преобразует текст в верхний регистр, то есть делает буквы заглавными.


=ПРОПИСН(А1:С1)

Как изменить регистр текста в Excel

Формула преобразовала строчные буквы в прописные

СТРОЧН. Переводит текст в нижний регистр, то есть делает из больших букв маленькие.


=СТРОЧН(А2)

СЧЕТ. Считает количество ячеек с числами.


=СЧЕТ(А1:В5)

Как сделать подсчет в Excel

Формула вычислила, что в диапазоне А1:В5 четыре ячейки с числами

СЖПРОБЕЛЫ. Убирает лишние пробелы. Например, когда переносите текст из другого документа и сомневаетесь, правильно ли там стоят пробелы.


=СЖПРОБЕЛЫ(А1)

Как удалить двойные пробелы в Excel

Формула удалила двойные и тройные пробелы

Сложные

ПСТР. Выделяет определенное количество знаков в тексте, например одно слово.


=ПСТР(А1;9;5)

  1. Введите =ПСТР.
  2. Кликните на ячейку, где нужно выделить знаки.
  3. Укажите номер начального знака: например, с какого символа начинается слово. Пробелы тоже считайте.
  4. Поставьте количество знаков, которые нужно выделить из текста. Например, если слово состоит из пяти букв, впишите цифру 5.
Как использовать функцию ПСТР в Excel

В ячейке А1 формула выделила 5 символов, начиная с 9-го

ЕСЛИ. Анализирует данные по условию. Например, когда нужно сравнить одно с другим.


=ЕСЛИ(A1>25;"больше 25";"меньше или равно 25")

В формуле указали:

  • А1 — ячейку с данными;
  • >25 — логическое выражение;
  • больше 25, меньше или равно 25 — истинное и ложное значения.

Первый результат возвращается, если сравнение истинно. Второй — если ложно.

Как использовать функцию ЕСЛИ в Excel

Число в А1 больше 25. Поэтому формула показывает первый результат — больше 25.

СУММЕСЛИ. Складывает числа, которые соответствуют критерию. Обычно критерий — числовой промежуток или предел.


=СУММЕСЛИ(В2:В5;">10")

В формуле указали:

  • В2:В5 — диапазон ячеек;
  • >10 — критерий, то есть числа меньше 10 не будут суммироваться.
Как использовать функцию СУММЕСЛИ в Excel

Число 8 меньше указанного в условии, то есть 10. Поэтому оно не вошло в сумму.

СУММЕСЛИМН. Складывает числа, когда условий несколько. В формуле указывают диапазоны — ячейки, которые нужно учитывать. И условия — содержание подходящих ячеек. Например:


=СУММЕСЛИМН(D2:D6;C2:C6;"сувениры";B2:B6;"ООО ХY")

  • D2:D6 — диапазон, из которого суммируем числа;
  • C2:C6 — диапазон ячеек для категории;
  • сувениры — условие, то есть числа другой категории учитываться не будут;
  • B2:B6 — диапазон ячеек для компании;
  • ООО XY — условие, то есть числа другой компании учитываться не будут.
Как использовать функцию СУММЕСЛИМН в Excel

Под условия подошли только ячейки D3 и D6: их сумму и вывела формула

Комбинированные

В Excel можно комбинировать несколько функций: сложение, умножение, сравнение и другие. Например, вам нужно найти сумму двух чисел. Если значение больше 65, сумму нужно умножить на 1,5. Если меньше — на 2.


=ЕСЛИ(СУММ(A1;B1)<65;СУММ(A1;B1)*1,5;(СУММ(A1;B1)*2))

То есть если сумма двух чисел в А1 и В1 окажется меньше 65, программа посчитает первое условие — СУММ(А1;В1)*1,5. Больше 65 — Excel задействует второе условие — СУММ(А1;В1)*2.

Как использовать несколько функций в Excel

Сумма в А1 и В1 больше 65, поэтому формула посчитала по второму условию: умножила на 2

Встроенные

Используйте их, если удобнее пользоваться готовыми формулами, а не вписывать вручную.

  1. Поместите курсор в нужную ячейку.
  2. Откройте диалоговое окно мастера: нажмите клавиши Shift + F3. Откроется список функций.
  3. Выберите нужную формулу. Нажмите на нее, затем на «ОК». Откроется окно «Аргументы функций».
  4. Внесите нужные данные. Например, числа, которые нужно сложить.
Как вставить формулу в Excel

Ищите формулу по алфавиту или тематике, выбирайте любую из тех, что использовали недавно

Как скопировать

Если для разных ячеек нужны однотипные действия, например сложить числа не в одной, а в нескольких строках, скопируйте формулу.

  1. Впишите функцию в ячейку и кликните на нее.
  2. Наведите курсор на правый нижний угол — курсор примет форму креста.
  3. Нажмите левую кнопку мыши, удерживайте ее и тяните до нужной ячейки.
  4. Отпустите кнопку. Появится итог.
Как скопировать функцию Excel

Посчитали сумму ячеек в трех строках

Как обозначить постоянную ячейку

Это нужно, чтобы, когда вы протягивали формулу, ссылка на ячейку не смещалась.

  1. Нажмите на ячейку с формулой.
  2. Поместите курсор в нужную ячейку и нажмите F4.
  3. В формуле фрагмент с описанием ячейки приобретет вид $A$1. Если вы протянете формулу, то ссылка на ячейку $A$1 останется на месте.

Как поставить «плюс», «равно» без формулы

Когда нужна не формула, а данные, например +10 °С:

  1. Кликните правой кнопкой по ячейке.
  2. Выберите «Формат ячеек».
  3. Отметьте «Текстовый», нажмите «ОК».
  4. Поставьте = или +, затем нужное число.
  5. Нажмите Enter.

Главное о формулах в Excel

  • Формула состоит из математических знаков. Чтобы ее вписать, используют символы = ( ) ; : .
  • С помощью простых формул числа складывают, умножают, округляют, извлекают из них квадратный корень. Чтобы отредактировать текст, используют формулы поиска, изменения регистра, удаления лишних пробелов.
  • Сложные и комбинированные формулы помогают делать объемные вычисления, когда нужно соблюдать несколько условий.
img
Подпишитесь на рассылку, чтобы Не упустить что-нибудь новое
Просто и понятно о том, как получить новую профессию


    Дадим нужные знания и поможем получить работу!
    Регистрируйтесь на курс и учитесь у экспертов-практиков.
    Навык
    за 2 месяца
    Excel для анализа данных

    Excel — незаменимый инструмент для бухгалтеров, экономистов, маркетологов, менеджеров, предпринимателей и аналитиков. Но мало кто умеет профессионально им пользоваться. После курса вы поймете, что Excel — это не только таблицы.

    6 320 ₽
    Ещё по теме
    img
    Аналитика
    Юнит-экономика: что это такое и как ее рассчитать

    С помощью unit-экономики прогнозируют доход, находят точки роста.

    16 апреля 2022
    9 мин
    юнит-экономика
    img
    Аналитика
    Кто такой менеджер по продукту, чем он занимается и как им стать

    Product manager отвечает за все стадии работы над продуктом.

    03 марта 2022
    9 мин
    product
    product manager
    img
    Аналитика
    Что такое когортный анализ: для чего и где применять, как проводить исследование

    В когорту входят пользователи, совершившие одинаковое действие в одно время.

    02 марта 2022
    7 мин
    когоротный анализ
    img
    Аналитика
    Что такое дашборд и как его создать

    Дашборд экономит время и помогает увидеть ситуацию с разных сторон.

    24 февраля 2022
    11 мин
    дашборд
    инструменты
    img
    Аналитика
    Кто такой аналитик и как им стать

    Аналитик нужен в любой сфере, где систематизируют и исследуют большие данные.

    24 февраля 2022
    12 мин
    аналитик
    профессии